Kompabilitas versi keras dengan Tensorflow 2.0

By | March 21, 2021
332 Views

Saat ini tensorflow sudah mencapai versi 2.2 keatas yang punya perbedaan yang jauh sekali dengan versi 1.0. Saya punya pengalaman menarik ketika menggunakan PlaidML sebagai backend pengganti tensorflow, dimana PlaidML tersebut masih dengan versi 0.7.0 yang punya ketergantungan dengan versi keras 2.2.4

Kendala ketika menggunakan tensorflow 2.2 dengan keras  2.2.4 terjadi konflik karena tidak adanya

AttributeError: module 'tensorflow' has no attribute 'get_default_graph'

https://stackoverflow.com/questions/55496289/how-to-fix-attributeerror-module-tensorflow-has-no-attribute-get-default-gr

Nah ternyata keras harus di upgrade ke 2.3.1 sesuai dengan link berikut

https://stackoverflow.com/questions/62690377/tensorflow-compatibility-with-keras

Jadi terpaksa dengan PlaidML nya tidak saya gunakan sementara lagi, kalau mau pakai lagi maka harus downgrade versi Keras sesuai dengan message dari PlaidML yaitu

plaidml-keras 0.7.0 requires keras==2.2.4, but you’ll have keras 2.3.1 which is incompatible.

Daripada saya downgrade tensorflow ke 1.0 ataupun melakukan teknik seperti ini https://www.tensorflow.org/guide/migrate yang nggak mempan sama sekali

Leave a Reply

Your email address will not be published.




Enter Captcha Here :